Out-of-Path with Policy-Based-Routing Redirection : Configuring the Router to Redirect Traffic

Configuring the Router to Redirect Traffic
The purpose of configuring the router is to redirect outbound traffic to the Silver Peak appliance.
This section provides examples of scripts to use for configuring policy-based routing with Cisco routers and with Juniper routers. Juniper’s nomenclature for PBR is FBF (Filter-based Forwarding):
n
n
CAUTION Do not enable this PBR on the interface to which the Silver Peak appliance connects.
To gain access to the CLI, access the router via the console port or a Telnet session.
Using a Cisco Router for Policy-Based Routing (PBR)
Here, we’ll configure PBR on the Cisco router and add an SLA (Service Level Agreement) to verify the appliance’s reachability.
This section shows a configuration of a Cisco router:
n
An access list is used to match traffic from the local LAN that should be redirected to the Silver Peak appliance.
n
The route-map is used to configure the next hop IP address (the Silver Peak), and points at the ip sla to verify reachability.
n
The ip policy is applied to the local LAN interface to intercept traffic that needs to be redirected to the appliance.
Note If the Silver Peak appliances are using auto-optimization but not enabling subnet sharing, then the route-map on the Cisco router also needs to be applied to the WAN interface to intercept incoming traffic from the WAN that’s not in a tunnel between the Silver Peaks. Also, an additional access-list entry would be required, with the source and destination subnets reversed to match the traffic coming in on the WAN interface. This does not apply to the example as implemented in this chapter.
If the Silver Peak appliance is not directly connected to the router/switch that is doing the redirection, use an IP SLA statement to ensure that traffic is redirected only when the Silver Peak appliance is Up.
configure terminal
 
ip sla 1
icmp-echo 10.110.31.100
ip sla schedule 1 life forever start-time now
 
track 1 ip sla 1 reachability
 
access-list 101 permit ip 10.110.33.0 0.0.0.255 10.110.11.0 0.0.0.255
 
route-map silverpeak permit 10
match ip address 101
set ip next-hop verify-availability 10.110.31.100 1 track 1
 
exit
 
interface gigabitEthernet 3
ip route-cache policy
ip policy route-map silverpeak
 
end
write mem
Using a Juniper Router for Filter-Based Forwarding (FBF)
Following is an example of how to configure filter-based forwarding [FBF] in JUNOS.
Assuming the default route is:
routing-options {
static {
route 0.0.0.0/0 next-hop 192.168.0.1;
}
}
1
 
set routing-instances redirect_sp instance-type virtual-router
set routing-instances redirect_sp routing-options static route 0.0.0.0/0 next-hop <IP address of Silver Peak WAN0> metric 5
set routing-instances redirect_sp routing-options static route 0.0.0.0/0 next-hop 192.168.0.1 metric 20
 
This routing instance creates a new default route directing traffic to the Silver Peak appliance. Note the route with the higher metric. If the first route is unreachable, traffic will be directed via the second route.
 
2
 
set routing-options interface-routes rib-group inet sp-forwarding
set routing-options rib-groups sp-forwarding import-rib [ inet.0 redirect_sp.inet.0 ]
 
3
 
set firewall family inet filter silverpeak_fbf term 1 from source-address 172.60.10.0/24
set firewall family inet filter silverpeak_fbf term 1 then routing-instance redirect_sp
set firewall family inet filter silverpeak_fbf term default then accept
 
This simply creates a filter that says traffic from Site A should use the created routing instance. That is, traffic from 172.60.10.0/24 should use 172.70.10.101 as its default route.
 
4
Apply the filter to an interface. Note that similar to PBR, the filter should not be applied to the interface directly connected to the Silver Peak appliance.
 
set interfaces ge-1/0/0 unit 0 family inet filter input silverpeak_fbf
Once a commit is executed, traffic that matches the filter is redirected.
Note This configuration is valid for a Silver Peak appliance that is directly connected to the Juniper device.

Please send comments or suggestions regarding user documentation to techpubs@silver-peak.com.