Out-of-Path with Policy-Based-Routing Redirection : Configuring the Router for Policy-Based Routing (PBR)

Configuring the Router for Policy-Based Routing (PBR)
This section describes the following two related tasks:
n
n
Cisco WAN Router Configuration at Site A
1
IP SLA tracks the Silver Peak appliance, and removes the policy route when the appliance becomes unreachable. This effectively prevents a routing “black hole” from occurring, where the router is sending traffic to an unreachable appliance.
 
ip sla 1
icmp-echo 172.70.10.101
frequency 5
ip sla schedule 1 life forever start-time now
!
track 123 ip sla 1 reachability
 
2
The access list needs to match the traffic you wish to optimize with the Silver peak appliance. The route map creates the policy based routing feature, and uses the access list to define what traffic to route to the Silver Peak. Traffic passing through the router that does not match this access list will not be sent to the Silver Peak, and will not be optimized.
 
access-list 101 permit ip 172.60.10.0 0.0.0.255 172.80.10.0 0.0.0.255
!
route-map silverpeak-lan-to-wan permit 10
match ip address 101
set ip next-hop verify-availability 172.70.10.101 1 track 123
 
 
3
Apply the policy route-map named silverpeak-lan-to-wan to the LAN interface. For multiple LAN interfaces, apply the policy route-map to each LAN interface with traffic to be optimized, this includes physical interfaces, sub-interfaces, or BVI interfaces (Layer 3 VLAN interfaces).
Note Do not apply the policy route-map to the interface connected to the Silver Peak (in this example, GigabitEthernet0/0), or you will create a routing loop.
interface GigabitEthernet0/0
description Connected to Silver Peak WAN0
ip address 172.70.10.1 255.255.255.0
 
interface GigabitEthernet0/1
description Connected to LAN
ip address 172.60.10.1 255.255.255.0
ip policy route-map silverpeak-lan-to-wan
 
interface GigabitEthernet0/2
description Connected to WAN
ip address 1.1.1.1 255.255.255.252
PBR with Silver Peak’s Auto-Optimization Feature
In the preceding example, the Cisco router will only redirect outgoing traffic (from the LAN out to the WAN) to the Silver Peak. For Silver Peak’s Auto-Optimization feature to work in this Policy-Based Routing scenario, the router also must forward the return traffic to the Silver Peak appliance (from the WAN incoming to the LAN). To accomplish this, we need to configure a routing policy to match the incoming traffic from the WAN.
1
 
access-list 102 permit ip 172.80.10.0 0.0.0.255 172.60.10.0 0.0.0.255
!
route-map silverpeak-wan-to-lan permit 10
match ip address 102
set ip next-hop verify-availability 172.70.10.101 1 track 123
 
2
 
interface GigabitEthernet0/2
description Connected to WAN
ip address 1.1.1.1 255.255.255.252
ip policy route-map silverpeak-wan-to-lan
 

Please send comments or suggestions regarding user documentation to techpubs@silver-peak.com.